
1 
 

 
Making the Most of Merge Letters 

 
Basics 

Why Use Merge Letters? 
-More accurate 
-Saves time 
-“Never type the same thing twice!” 

Review 

What is a Merge Document? 
The part of the merge operation that includes the text that does not change per document. 

What is a Data Source? 
A data source supplies the Merge Letter with the text that changes in each letter – for example, the inside address 
information.  In Pearl, the data source for a merge letter is a query. 
 
The Pearl query includes any fields that will be used in the letter, will define the SORT order – the order in which 
the letters will print, and includes any criteria that defines which records the merge letters will print for. 
 
Word merge letters will always retrieve the latest information from the data source records. 
 

 
Section 1: Before You Begin: Baseline Conditions for Successful Pearl Letters 

1. All Pearl users should have the same version of Microsoft Office with all available service packs installed. 
2. All Microsoft Office applications (Access, Excel, Word) should be the same version (i.e., don’t mix Access 

2003 with Word 2002). 
3. Pearl should be updated to at least v. 4.17. 
4. The user on the machine that opens Pearl must have read/write/edit permissions on Pearl’s root directory and 

all subfolders. 
5. All workstations must have Pearl mapped to the same drive in the same way. Terminal server sessions must 

also use that same mapping. 
6. Merge letters created for Pearl must use the same drive mapping used to open Pearl (stored in the target 

property of the shortcut to Pearl). 
 
Note: You will likely encounter problems if any of these conditions are not met. 
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Section 2: Creating a New Letter 
 
Create a new query.  
 

1. Name the query in a way that clearly associates it with the letter it will be used for (examples: 
qryNotificationLetterDoc or qryNotificationLetter and Notification Letter.doc, qryNotifyDoc or 
qryNotifyLetter and Notify.doc).   

 
2. If the query’s SQL statement exceeds 510 characters, you may get a message that the letter is not a merge 

document. Instead, base your new query on one of Pearl’s full queries and only select the fields that will be used 
in the merge letter and fields on which to set criteria. 

 
3. During the initial design phase or while editing an existing letter, use criteria in the query (like Num<10) to limit 

temporarily the size of the record set to 10 or less records. This will save time in viewing the merge to preview 
changes while composing the document. Remove the criteria after you are satisfied with the design and are ready 
to run the full merge. 

 
4. Using a query with a parameter prompt might only work if opening the letter from the letters folder. You may get 

an automation error if you attempt to open the letter from Pearl Navigator. Keep in mind that Pearl Set commands 
will not work unless the letter is opened from Pearl Navigator. 
 

5. Please note: The merge-to-Chronicle feature will only work for the Chronicle of the main table in the 
query, and only if the key field of that table is in the query once. Keep in mind that that Constituent List 
and Contacts Tracking share the same Chronicle system: CLIST Chronicle, so be sure to include the Ser 
field in queries based on CONTACTS or CLIST. If the key field of the main table is not included in the 
query, Pearl will automatically insert [Pearl Chronicle No] as the first line in your merge letter and handle 
it accordingly. 

 
Create the letter. 
 

1. In Pearl Navigator, go to Letters and click New. Select the query you just created as the data source, then click 
OK. 

 
2. Compose the letter using the fields available in the query. Save when finished. 

 
3. If you want the letters to be automatically saved to Pearl Chronicle, add this line of hidden text at the beginning of 

the letter in design view: 
 

 
 
 
 
 
 
 
 
 
 



3 
 

 
 
 
 
 
 
 
 

4. If you do not want the letters to be saved to Chronicle, add this line of hidden text at the beginning of the letter in 
design view: 
 

 
 

5. If neither [Pearl chronicle Yes] nor [Pearl Chronicle No] is added to the beginning of the letter in design view, 
Pearl will offer to save the letters to Chronicle at the time the merge is executed. 
 

6. Test the letter by previewing it from Pearl Navigator. If the size of the query’s record set is not limited by criteria, 
use a filter when previewing the letter. 

 
 
Section 3: Reattaching a Letter to its Data Source 
 

1. Identify the query in Pearl that the letter needs to be connected to. Unhide the database window in Pearl and 
find the query in the list of query objects. Open the query to find out how many records are in the record set. If 
there are more than 20 to 30 records, go to design view and change the criteria (this can be temporary) so 
that there are less than 30 records that display when the query is run. (For example, change the criteria for 
Dco from >#6/1/2007# to >#6/1/2008.) Save changes. 

 
2. Close Pearl. Open the letter in the Pearl\Letters\ folder (using the common mapped drive) with Word. If you 

get a message that Word could not find the data source, click the Options button, then click on the Remove 
Data/Header Source. If you do NOT get that message, continue with step 3. 

 
3. In the Tools menu, select Letters and Mailings>>Mail Merge…. On step 3 of 6, click on “Select different data 

source” or “Browse” depending on whether you had to click through the message boxes in step 2. Navigate to 
Pearl.mdb using the common mapped drive for Pearl. Select Pearl.mdb and click Open. 

 
4. In the Confirm Data Source box, select the DDE connection and click OK. Find and select the query from 

Step 1, make sure the Link to Query checkbox is checked and click OK. Click OK when the merge records 
display. Close the Letter and save changes. 

 
5. Open Pearl and verify that the merge is working as expected when you open the letter in Preview mode from 

Pearl Navigator. Initially, two Word documents should open, then one of them will close after the merge is 
executed. 
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Section 4: Running Merge Letters 
 
With [Pearl Chronicle Yes] 
 
The merge will execute and you will receive this message. If you have a Set Command in the letter, Pearl will indicate 
how your data will be updated. 
 

 
 
Caution: The message may be hiding behind the Word document. Do not close the merge document before clicking OK 
or Cancel – Pearl will close it for you. 
 
 
 
Each letter will have a line of hidden text indicating the source record in Pearl. Pearl will attach the letter to the 
corresponding record in Pearl Chronicle. 
 

 
 
 If you choose to send your letters to Chronicle, you still have the option of saving the Letters1 document as one 
large document from Word. Keep in mind, however, that any changes you make to that document after saving the 
letters to Chronicle will not be reflected in the individual letters in Chronicle.
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Section 4: Running Merge Letters (cont.) 
 
With [Pearl Chronicle No] 
 
Please note: If the query behind your merge letter does not include the key field of the main table in your query, 
Pearl will automatically make your merge letter a [Pearl Chronicle No] letter. 
 
If you have a Set Command in the letter, Pearl will indicate how your data will be updated. If you do not have a Set 
Command in the letter, you will not get a message. 
 

 
 
Caution: The message may be hiding behind the Word document. Do not close the merge document before clicking OK 
or Cancel. Pearl will not automatically close the letter if it is set to [Pearl Chronicle No]. 
 
 
 
Each letter will have a line of hidden text indicating the source record in Pearl, but will not save the letters to Chronicle. 
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Section 4: Running Merge Letters (cont.) 
Without [Pearl Chronicle Yes] or [Pearl Chronicle No] 
 
Pearl will first display a message about how to make processing to Chronicle automatic. Caution: The message may be 
hiding behind the merge letter. Pearl will offer to save a copy of each letter in Chronicle. 

 
 
If the key field of the main table is not included in the query, Pearl will automatically insert [Pearl Chronicle No] as the first 
line in your merge letter and handle it accordingly. When you click on the Yes or No button and if there is a Set Command 
in the Letter, Pearl will indicate how the data will be updated. If you select No and there is no Set Command, you will not 
get a second message. 

 
 
Caution: The message may be hiding behind the Word document. Do not close the merge document before clicking OK 
or Cancel, or you will get an error message. Pearl will not automatically close the letter unless you have chosen to save 
copies of the letter in Chronicle.
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Section 5: Tips and Tricks 
 
Fixing Letters: Avoid the frustration of attempting to fix a broken merge letter by copying the body of the broken letter into 
Notepad. Use this de-formatted text as the basis for a fresh merge letter using the steps in Section 2. 
 
Parameter prompts in queries: Parameter prompts will work with Pearl’s Word Automation, but you may experience 
special problems. We recommend using filters in Pearl Navigator to achieve the same results. 
 
For Office XP and higher: In Microsoft Word, click on the Tools dropdown menu and select Options.  Under the General 
tab, make sure the 'Confirm Conversion at Open' (about 4th one down) option is marked. As you are going thru the mail 
merge steps, after you select your data source (step 3), you'll get a Confirm Data Source box - make sure you select the 
MSAccess Databases via DDE (*mdb, *mde) option.   
 
Recipients List: If you are not seeing all records from the query in your merged document, check two things: 
 

1. In Design view, click on the Mail Merge Recipients icon. In the Mail Merge Recipients dialog box, click the arrow 
in front of one of the column headings and click (Advanced…). In the Query Options dialog box, click the Clear All 
button if there is any criteria applied. 

2. Be sure the record Navigator is set to #1. 
 
 
The best site for general Word merge tips: http://homepage.swissonline.ch/cindymeister/MergFram.htm 
 
 
 
Section 6: Pearl Set – Updating Fields in Pearl during the Merge Letter Procedure 
 
At the end of any Merge Letter you can imbed commands to update one or more Pearl fields that the Merge document 
“knows” about. 
 
The Pearl Set commands must be enclosed in square brackets in hidden text and adhere to the following format.   
[Pearl Set FieldToUpdate=Value]   (If case is altered from example, function does not work.) 
 
When you preview the merge letter from the Pearl Navigator, Microsoft Word is loaded, the template document is loaded 
and the merge automatically takes place to a new document. IT WON’T WORK IF YOU DON”T PREVIEW FROM THE 
NAVIGATOR 
 
Preview and print the merge letters, then close the new document (save it if you want).  Notice that the Pearl icon on the 
Start Bar is blinking, click on it and you’ll see a prompt asking if you want to update the field you specified with the data 
you specified.  If you respond “Yes”, you’ll see a second message that tells you how many records will be updated with 
that information.  If you’ve set more than one field to be update, the additional update questions will be displayed.  If you 
DON’T want the Pearl fields updated, click No when prompted. 
 
NOTE:  Since the Pearl Set command gets formatted as hidden text, you MUST turn on the formatting marks to show 
Hidden Text (In MSWord click on the Tool dropdown menu, select Options, under Formatting Marks section, check the 
Hidden Text option).  Important: This must be done after opening the letter from Pearl Navigator using the Design 
button; doing this after opening the letter from the Letters folder will not affect Word settings for Pearl’s use of 
Word Automation. The Pearl Set command should be the last line in the merge letter HOWEVER, do not make the final 
hard carriage return be hidden. You can verify that it is not by marking the ALL option under Formatting Marks.  
 
Examples of the field updates you can do:  
 
[Pearl Set DateField=DateAdd("m",-3,[date])] 
[Pearl Set DateField=Date()] 
[Pearl Set DateField=[Update DateField to what date?]] 
[Pearl Set DateField=Now()+1] 
 
[Pearl Set TextField=Null] 
[Pearl Set TextField="Minnesota"] 



8 
 

[Pearl Set TextField="State: "&[State]] 
[Pearl Set TextField=[Update TextField to what State?]] 
 
[Pearl Set NumField=1000] 
[Pearl Set NumField=iif([each]>500,[each]+100,[each])] 
[Pearl Set NumField=[each]+500] 
[Pearl Set NumField=Null] 
 
 
Section 7: Advanced Features 
 

“If Then Else” Statements 
Drop down menu on the Insert Word Field button on toolbar; Fill in the Fields to compare and the operator.  Type 
the text in the “insert this text” area which you would like to see in the merged document, if the comparison it true.  
In the area of the Window that says “Otherwise Insert this Text,” type in a place holder like, “XXXX”.  Then press 
Okay.  From your merge document, place the cursor at the place holder and start the If Then Else process over. 
 

What’s the Difference between Ask and Fill In? 
(Drop down menu on the Insert Word Field button on toolbar) 
 
A Fill-In Prompts you to enter text. Your response is printed in place of the field.  The prompt is displayed each time 
a new data record is merged unless you choose the Ask Once checkbox. 

 

Displaying Dates 
To track when a document was created, last printed, or last saved, click Field on the Insert menu, click Date and 
time in the Categories box, and then insert a CREATEDATE, PRINTDATE, or SAVEDATE field. You can use 
options with these fields to print the date, the time, or both. 
 

Switch formatting (dates and numbers) 
 
When you merge number and date fields from an Access query, the format of those fields will appear as they are 
stored in the database – for instance, a date may appear as  12/25/2005 instead of December 25, 2005, a number 
may appear as 10000  rather than $10,000 or a text field may display ‘capital campaign’ for the program name rather 
than ‘Capital Campaign’ or ‘CAPITAL CAMPAIGN’.  To format information coming into the merge letter, you 
must include formatting with the {MERGE FIELD } instructions – these formatting instructions are called 
‘Switches’. 
 
Text Switches 
If the Program field in Access is stored as  ‘capital campaign’ and you’d like it displayed as ‘Capital Campaign’, set the 
following switch: 
 
{ PROGRAM  \* Caps }  \* is the text formatting switch  
 Caps indicates to capitalize the first letter of each word 
 
Other Text Switches:  \* FirstCap  capitalize the first letter of the first word (Capital campaign) 
 \* Upper capitalize the entire value (CAPITAL CAMPAIGN) 
 \* Lower all letters lower case (capital campaign” 
 
Numeric Switches 
If the Grant field in Access is stored as  10000 and you’d like it displayed as $10,000 set the following switch: 
 
{ GRANT \# $#,##0 }  \# is the numeric formatting switch  ($10,000.00) 
 
To include the two decimal places use  \# $#,##0.00  as the switch 
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Date Switches 
If the DRE field in Access is stored as  12/25/2005 and you’d like it displayed as December 25, 2005 set the following 
switch: 
 
{ DATE \ @ "MMMM d, yyyy"}  \@ is the date formatting switch 
 
To include the day of the week – Sunday  use the following switch: 
\@ “dddd MMMM d, yyyy” Sunday December 25, 2005 
 
To abbreviate the month  - Dec    
\@ “MMM d, yyyy” Dec 25, 2005 
 
To use only the month name of the date – December 
\@ “MMM” December 
 
To include the time 
\ @ "dddd MMMM d, yyyy', at' h:mm". Monday October 21, 2002 at 10:09 
 
 

Sending Merge Documents Electronically 
Include the contact’s email field in the query in Pearl.  From the Merge Window in your Word Document, drop 
down the list for “Merge To” and change option to Electronic mail. 

 
 
Section 8: Trouble Shooting 
 
Where Are those “Darn” Merge Letters? 

Merge letters are stored in the Pearl\letters folder on the server if on a network. 

Alternative Ways to Open a Merge Letter. 
Open Microsoft Word; then open document; continue using the Mail Merge Helper if necessary open query in 
design view; click Office Links on Tools menu, Merge with MS Word; choose to Create or link to an existing 
merge document; Save in the Pearl\Letters subfolder. 

Multiple Copies of Pearl Open when Previewing 
Typically, multiple copies of Pearl opening is caused by the path set for the shortcut key to Pearl being different 
than the path Microsoft Word is using when linking the merge document to the data source.  Check the properties 
of the Shortcut to Pearl to see how it is mapped. 

Merged Document Lost Records 
Check if criteria is correct in (Access) query. 

Check if Query Options (MS Word) are set in Merge Document. 

Blank Lines Appear in Address of Merged Letter 
From the Merge window, under “When merging records,” choose the option, “Don’t print blank lines when data 
fields are empty.”  

Toggling Field Codes 
Use F9 to toggle one field code or right click on Field code and choose “Toggle Field Codes” 

Use Alt +F9 to toggle field codes for whole document 
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Changing Word Field Options 
To always see the field codes in the main document, click Options on the Tools menu, click the View tab, and 
select the Field Codes check box.. 

To show field shading in the main document, click Options on the Tools menu, click the View tab, and select 
“Always,” “When selected” or “Never” from the Field Shading box. 

If Field codes are printed instead of the value, information click Options on the Tools menu, click the Print tab, 
and then clear the Field codes check box. 

Field Codes appear but no results when merged 
It is critical that Insert Word Field instead of typing the squiggly brackets ({ }) and typing a field.  If you manually 
type it, it may appear the same as the correct method but Word does not interpret them as being equal. 

Field is not Updating 
It could be that the field is locked.  To lock a field and prevent changes to the current field results, click the field, 
and then press CTRL+F11.  To unlock a field and allow updates, click the field, and then press 
CTRL+SHIFT+F11.  

 


